The Saleen Forums at soec.org

The Saleen Forums at soec.org (https://saleenforums.soec.org/index.php)
-   2018-Present Saleen STX Sportruck (https://saleenforums.soec.org/forumdisplay.php?f=131)
-   -   2020 yellow label Sportruck XR issues, anyone else? (https://saleenforums.soec.org/showthread.php?t=22961)

gnomemade 09-21-2020 04:30 PM

2020 yellow label Sportruck XR issues, anyone else?
 
I bought a yellow label, #14, back in June. I've had a few problems with mine and wondering if anyone else has had problems? I really do love the truck but I've lost confidence in it and I'm pretty unhappy with Saleen and my dealer right now.

My issues:

- On a drive to CO from TX it had issues in Colorado Springs. I as normally accelerated to get on the interstate (normal, nothing aggressive) the engine bogged down, a collision detection not active warning popped and the SES light turned on (codes P0111, P059F and P061A). After that it had very little power, the gear indicator would get up to 4, 5+ but the truck barely moved. Dealer in CO said the intercooler was installed "upside down" and was blocking the grille shutters. Makes no sense considering I drove through hot *** Texas in early July with no issues but the truck had problem in very comfortable CO temps. After they had it a week I picked it up, drove the 3 hours to my house and all seemed well.

- The day after picking it up, while running an errand, the SES light came back on and the engine was surging while trying to hold a steady speed. Got home and the rubber grommet holding a vacuum line into the intake had sheared in half and the hose wasn't holding. Pretty sure this was the dealership in CO Springs fault, the vacuum hose was going against the bend in it. I had contact at Saleen from the prior issue and he was supposed to have Edelbrock overnight me the grommet but 5 days later I hadn't received it and needed to drive back to Texas. I ended up gluing the grommet back together and then using zip ties to hold it in place :biggrin: I made it a couple hours to Canon City CO and SES came on again. My vacuum line rigging was still in place but acceleration was very touchy. From a stop it was hard to not keep it from really getting up and going but at 60mph it took a good push of the accelerator to get to 65 or 70. Back in TX took it to my dealer who after 2 weeks said that the intercooler was bad and needed to be replaced. After 2 more weeks of excuses for not getting the replacement part they finally got it in, I picked it up and drove it for 3 weeks with no issues. At this point my truck had been in dealerships for longer than I had possession of it. I made my first payment while it was in the shop :mad:

- Yesterday, I was driving back to CO and was about 5 hours into this leg of the trip. I had cruise on 68 when I hit a relatively long but not that steep hill on a back road. The engine downshifts and accelerates to keep speed. Once again I get an instant loss of power, the collision detection not active warning pops but this time a gear icon shows up on the console. I had to look in the manual to see what that icon represented. I was in 2 wheel high when this happened so I can't imagine it's an issue with 4wd. After this happened the tranny would have a noticeable jerk when going from 2-3 or 3-2 and would make it up to 8 or 9 and stay there, even when reducing speed to say 40mph or so. I pulled over, turned the car off and back on and the wrench light went away. The weird lack of downshifting went away and the jump at 2-3 wasn't as noticeable. But, I was really babying it since I was 3 hours away from home in an area with no mobile service for 75% of the remainder of the trip.

When I got home I looked at the DTC codes and saw P061A again in a "DTC Maturing" status. The only other codes were the codes below that seem to be intermittent comm issues between modules:


Code: P061A - Internal Control Module Torque Performance
- DTC Maturing - Intermittent at Time of Request

Code: U0422 - Invalid Data Received From Body Control Module
- DTC Present at Time of Request

Code: U0100 - Lost Communication With ECM/PCM A
- Previously Set DTC - Not Present at Time of Request

Code: U0140 - Lost Communication With Body Control Module
- Previously Set DTC - Not Present at Time of Request

Code: U0140 - Lost Communication With Body Control Module
- Previously Set DTC - Not Present at Time of Request

Code: B1088 - LIN Bus B
- Missing Message

Code: U0401 - Invalid Data Received from ECM/PCM A
- Signal Invalid

Code: U0418 - Invalid Data Received from Brake System Control Module A
- Signal Invalid


Long story, I know but it was nice to type it up and vent about it :) Anyway, I'm curious if anyone else has had issues with the new Sportruck or if anyone has ideas about the problems above.

haulin S331 09-22-2020 09:59 AM

Sport Truck
 
I would give JDM a call at 732-780-0770 and talk to Jim sr. or Jim jr. they know about the SALEEN brand very good people to work with , Hope that helps Haulin s331sc #309.


All times are GMT -4. The time now is 07:53 AM.