The Saleen Forums at soec.org

The Saleen Forums at soec.org (https://saleenforums.soec.org/index.php)
-   1999-2004 Saleen Mustang (https://saleenforums.soec.org/forumdisplay.php?f=62)
-   -   Help: 2004 boost pressure gauge not working (https://saleenforums.soec.org/showthread.php?t=22308)

fastsilverstang 02-08-2019 07:53 PM

Help: 2004 boost pressure gauge not working
 
Hi all!

Hope someone can help me out. I've been looking all around online for a possible fix for my boost pressure gauge not moving.

I read online that it could be the sending unit so I replace it with a new - Stewart Warner Performance Gauge Sending Unit 82504-F but that didn't fix it ....

So can it be:
A grounding issue? If so, where should I look?


The Boost bypass valve? Any ideas on what bypass valve will work on the Supercharger Series IV? Link to buy a new one?

fastsilverstang 02-17-2019 05:15 PM

Still stuck on how to fix the boost gauge. Any suggestions or help!?

Does any one know what bypass value is used on 2004 Saleen Series IV supercharger? What supercharger do they use, Eaton or Lysholm?


Will this work? http://www.brenspeed.com/saleen-bypass.html

DarkStallion 02-19-2019 12:00 AM

boost gauge
 
Well if you did the sender and that is hooked up right, your left with a power issue or the ground issue. You are getting the variable voltage from the sender, but you are still getting actual power from I believe the gauge cluster. Correct me if I am wrong anyone. Also your best bet is going to the source and pulling the gauge itself but you have to pull your radio out and maybe your cluster which sucks. Never been in there on a 99 04 car, but you can only test the gauge by getting in there. Let us know. Oh take a look at the center gauge pod install instructions I believe they show an 03 04 set up.

jwright1982 02-22-2019 09:00 PM

Are you sure your getting boost I had the same problem on my 99 and 02 the dealer couldn’t figure it out and tried replacing all kinds of stuff. My father was with me and while looking under the hood and the dealer noticed that the vacuum line on the side of the supercharger that connects to the bypass valve was unhooked put it back on and worked ever since. Same thing happened a few years later in the 02 might not be your problem but worth a check. Best of luck

BillGood 08-25-2019 10:59 PM

i have 04-363 with the type IV sc
mine is a lysholm 2 screw 1600 hope this helps


All times are GMT -4. The time now is 10:59 PM.