The Saleen Forums at soec.org

The Saleen Forums at soec.org (https://saleenforums.soec.org/index.php)
-   2008-2009 Racecraft Mustang (https://saleenforums.soec.org/forumdisplay.php?f=86)
-   -   Speedometer Calibration? (https://saleenforums.soec.org/showthread.php?t=9002)

Cwarre9 12-29-2010 01:12 PM

Speedometer Calibration?
 
Does anyone have any info on calibration of the speedometer? I'm consistently 4 to 5 MPH fast. Spoke with both dealers in my area and got the "that's within tolerance" answer. I've never had this issue with any car I've owned before, so it just doesn't seem right. May be the best I can get, but thought I'd ask the experts here. :smile:

Dave 12-29-2010 01:23 PM

The 2008-09 Racecraft Mustang used a 180MPH gauge face. The 2007 PJ and 2007-08 Heritage series also used a 180MPH face. Both 2007 PJ and 2007 S281 Heritage are known for having their clusters calibrated incorrectly.

Speak with SPV warranty and see if your cluster can be re-calibrated.

David Rivard 12-29-2010 01:57 PM

Cwarre9,

I cal all the clusters here at Saleen and it is very typical to vary 2-3 MPH slow or fast , but the PJ had speedos that were anywhere from 5-10 MPH slow in which the owners were receiving speeding tickets . It may not be the cluster that is off, it also could be the number of revs per mile programmed in the VID block of the PCM.

Cwarre9 12-29-2010 08:04 PM

Quote:

Originally Posted by Dave Rivard (Post 47873)
Cwarre9,

I cal all the clusters here at Saleen and it is very typical to vary 2-3 MPH slow or fast , but the PJ had speedos that were anywhere from 5-10 MPH slow in which the owners were receiving speeding tickets . It may not be the cluster that is off, it also could be the number of revs per mile programmed in the VID block of the PCM.

Thanks Dave;

Thanks for the response... Mine is running a little more than 3, I've had three different GPS units in the car and they all read close to the same. The speedometer is reading high, so I'm adding miles (if the odometer is connected to the speedometer) at the rate of 4 to 5 extra miles each hour. Plus, I seem to have everyone in California passing me on the freeway. Okay, bad point - it is California!

Thanks again. Looks like I'll have to live with it.

Cliff

Meikol02 12-29-2010 11:22 PM

Quote:

Originally Posted by Cwarre9 (Post 47869)
Does anyone have any info on calibration of the speedometer? I'm consistently 4 to 5 MPH fast. Spoke with both dealers in my area and got the "that's within tolerance" answer. I've never had this issue with any car I've owned before, so it just doesn't seem right. May be the best I can get, but thought I'd ask the experts here. :smile:


My car runs the same delta as yours, but I have never tried to correct it.

S281SC Coop 01-01-2011 11:04 AM

I had the same issue with the clock on the dash running at a different speed than what my GPS unit was telling me I was going. A couple things are going to affect, the first being your rear-end gear ratio. If you have a hand held tuner (SCT) you need to hook it up and be sure you have the correct ratio "loaded" into the cars computer. The second thing that is going ot affect it is your tires RPM (revoultions per mile) this is something you can toy around with but you have to reload it everytime you change the perameter.

http://www.discounttiredirect.com/di...foTireMath.jsp

If I remember correctly mine was set around 735 and this was way off. my clock was telling me I was going 70 and my GPS said I was only doing 66,,,67. but taking that 735 number higher I was finally able to get my GPS and clock to agree on the same speed. Good luck

QWKENUF
Craig

Barricade 01-02-2011 09:13 AM

You can adjust the Revs per mile (tire size) in your tune which would fix that.

S281SC Coop 01-02-2011 09:40 AM

That is correct. Although I found, I still had to use a higher number than (the rpms from) that website said I should be at. I dont know why that is. That is the reason I said you can toy around with it to ....its more to "fine tune" it actaully

goldy 02-22-2011 10:37 PM

I have an 06 S281 Canadian version and i was stopped for speeding because my speedo was out by 10%. So when I was doing 119km/hr i was actually doing 131 which caused me to be charged with 30km over the limit> I was not a happy camper, so i guess it happens, now i just keep it inside the speed limits and usually don't get bothered.

goldy 02-22-2011 10:40 PM

also when i had my car tuned it was found that my tach is off about 4-500 rpm at 6000 as well< i have to watch that too< just the fun of having something that's not "stock"

OneQwkStang 05-16-2012 08:24 PM

Quote:

Originally Posted by goldy (Post 50694)
I have an 06 S281 Canadian version and i was stopped for speeding because my speedo was out by 10%. So when I was doing 119km/hr i was actually doing 131 which caused me to be charged with 30km over the limit> I was not a happy camper, so i guess it happens, now i just keep it inside the speed limits and usually don't get bothered.

Mine reads 10 km/h slower too.....

panohodges 05-16-2012 09:38 PM

I had the same issue. Ran about 5-10 MPH slower than speedometershowed. I had the car tuned on dyno and its been dead on with 2 GPS units and a phone app over the last 6 months.

I had gone to 2-3 ford dealerships and was told there was nothing they could do. They all suggested putting it on dyno to recalibrate.


All times are GMT -4. The time now is 06:16 AM.