View Single Post
  #1  
Old 06-13-2021
Bellum Bellum is offline
Saleen Forums Participant
 
Join Date: Apr 2021
Location: Franklin
Posts: 14
Default intermittent power loss during hard acceleration

First problem found with my car! It's a 2006 supercharged, This problem seems to be intermittent, where sometimes in 2nd and/or 3rd gear I'll try to do a pull and all of a sudden feels like I hit a brick wall, complete power loss rpms drop violently but the car stays running no check engine light. power comes right back and then I can try again and it will pull perfectly fine and smooth all the way up. I've never experienced a problem such as this, any advice would be greatly appreciated, the car has under 14k miles so it has sat a lot during it's life, I don't see any belt shavings/rubber under the hood by the pullies so I dont think the belt is slipping, car makes about 6lbs of boost in 2nd and 3rd gear, no fluid leaks anywhere in the car

Also, If anyone knows how to get an order placed successfully with 281motorsports PLEASE LET ME KNOW!! i've been trying to place an order for over a month, even got lucky and spoke with the guy jason on the phone and he has all my information and credit card, that was weeks ago and I can not get a hold of them and have received no replies since I gave all of my info, are they an actual business? am I just not important enough to become a customer? anyone know what the deal is? Is there anywhere else to order a supercharger oil dipstick? anyone have a spare to sell?

Last edited by Bellum; 06-13-2021 at 12:19 AM.
Reply With Quote