The Saleen Forums at soec.org header image

Go Back   The Saleen Forums at soec.org > Saleen Mustang Discussions > 2005-2009 Saleen Mustang
Register FAQ Members List Calendar Mark Forums Read

2005-2009 Saleen Mustang For all S281, S302, H281 and H302 models based on the Ford S-197 Mustang platform, with the exception of the S302 PJ (see below). Be sure to specify year, model and equipment if asking for help.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-06-2018
KGinPA KGinPA is offline
Saleen Forums Registrant
 
Join Date: Dec 2016
Location: Prospect, PA
Posts: 9
Default Help: IAT Gauge erratic behavior - 2007 S281 SC

I recently purchased 07-411 S281SC Convertible and the weather has been terrible here in PA so I haven't driven the car more than down the street and back. However, I noticed the Intake Air Temp gauge indicator bouncing from side to side while under power. Have any of you had that issue and what have you found to be the cause? It doesn't move while at idle.
Reply With Quote
  #2  
Old 03-07-2018
Meeker1's Avatar
Meeker1 Meeker1 is offline
SOEC Member
 
Join Date: Mar 2009
Location: Aurora, Il 60505
Posts: 117
Default

I had the same needle bouncing back and forth on boost gauge . . purchased new gauge from Speedlab but also erratic reading and returned . . Speedlab suggested checking sending unit and replace . . Would be great to hear from others on fix . .
Reply With Quote
  #3  
Old 06-04-2020
Meeker1's Avatar
Meeker1 Meeker1 is offline
SOEC Member
 
Join Date: Mar 2009
Location: Aurora, Il 60505
Posts: 117
Default

Still could use help and reply . . annoying issue and boost gauge still not working . . getting ready to pull her out from winter / virus storage and drive #1264. . Thnx
Reply With Quote
  #4  
Old 06-04-2020
tbar's Avatar
tbar tbar is offline
SOEC Member
 
Join Date: Aug 2010
Location: British Columbia, Canada
Posts: 615
Default

Did you replace the sending unit? That’s the only other thing that makes sense to me.
Reply With Quote
  #5  
Old 07-12-2020
Meeker1's Avatar
Meeker1 Meeker1 is offline
SOEC Member
 
Join Date: Mar 2009
Location: Aurora, Il 60505
Posts: 117
Default

Took a much closer look after ordering a new $50 sending unit from Velocity Products on ebay . . noticed nut that was supposed to be attaching unit was held on by a small zip tie . . unbelievable . boost gauge works great after replacing nut .. unfortunately Velocity Products will not take return on purchased unit . . Oh well
Reply With Quote
  #6  
Old 02-14-2021
06 Saleen 06 Saleen is offline
Saleen Forums Registrant
 
Join Date: Oct 2014
Location: Mechanicsville Va
Posts: 7
Default

Has anyone founded anymore information on this problem.
Thanks
Reply With Quote
  #7  
Old 4 Weeks Ago
Damageln Damageln is offline
Saleen Forums Participant
 
Join Date: Dec 2015
Location: Lutz
Posts: 45
Default

Mine was resolved when I replaced the air temp sensor (shared part with the Ford Lightning.) I also changed the intercooler pump and I haven't had an issue in over 2 years.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:42 PM.


Orders placed through these advertiser links help to support SOEC and this website.

Tire Rack Wheel Clearance

When you buy one Valeo® ULTIMATE™ Wiper Blade from Tire Rack, you'll get one free!

Dunlop $50 Rebate


| SOEC.ORG | ABOUT SOEC | MEMBERSHIP | SHOWROOM | LITERATURE | VEHICLE PRODUCTION | THE SALEEN TRADER | SALEEN AUTOMOTIVE | CONTACT SOEC | SOEC @ FACEBOOK |


All Original Content Copyright © 1991-2021 Saleen Owners and Enthusiasts Club, LLC (SOEC). All Rights Reserved.
SOEC is the official independent, non-profit organization for owners and enthusiasts of vehicles by Steve Saleen and Saleen Automotive, Inc.